Как сделать sms авторизацию для wifi на оборудовании mikrotik? — Хабр Q&A

Hotspot на оборудовании mikrotik с авторизацией через sms —

До недавнего времени бюджетный спутниковый доступ в интернет был исключительно ассиметричным (запрос проходил по наземным сетям связи, ответ “падал с неба”). Сейчас же одна известная трёхцветная кампания предлагает двунаправленный комплект по вполне демократичным ценам. Область применения, в первую очередь, для организации доступа в сеть в местах, куда прокладка наземной линии связи либо невозможна, либо слишком дорога.

Заказчиком была поставлена задача обеспечить доступом в Интернет охотбазу, расположенную в 60 километрах от города. Выезд на место показал наличие сотовых сетей, но 3G там только декларировался значком на дисплее телефона, а по факту — отсутствовал совсем. Попытка договориться с ОпСоСами о пробросе оптики от базовой станции, видневшейся вдали, привела к коммерческому предложению в 700 тысяч рублей за установку и 69 тысяч в месяц абонплаты за канал, что не могло не радовать. В тяжких раздумьях вбил в поисковую строку «Спутниковый интернет» и, о чудо, понял, что это – спасение.

Для реализации проекта было закуплено:

Процесс монтажа и настройки комплекта описывать не буду, ибо он мало чем отличается от монтажа обычной телевизионной тарелки и ресивера.

Приёмник имеет 10/100 RJ-45, который мы подключаем к маршрутизатору. Процесс настройки HotSpot-a описан во многих источниках, я делал по вот этому мануалу.

Ну а дальше – самое интересное. Так как лень, как известно, двигатель прогресса и ручками заносить каждого пользователя было лень решил автоматизировать процесс посредством рассылки пары Login/password через SMS.

Сначала необходимо скачать и установить на Mikrotik пакет user-manager. Сразу после перезагрузки панель управления будет доступна по адресу http://IP.of.you.router/userman.

Login: admin без пароля. Немедленно меняем. Для работы RADIUS сервера на Mikrotik создадим виртуальный маршрутизатор. Открываем терминал и вводим:

/tool user-manager router add customer=admindisabled=noip-address=127.0.0.1name=virtualshared-secret=123456789

Результат:

Похожее:  Что такое авторизации на сумму в Тинькофф банке? - Про деньги, инвестиции и расходы

HotSpot MikroTik с авторизацией через SMS

Создадим профиль trial1:

Как сделать sms авторизацию для wifi на оборудовании mikrotik? — Хабр Q&A

Преднамеренно сделано так, чтоб каждый пользователь работал на максимально возможной скорости. Система очень гибкая, имеет массу возможностей, описанных в документации.

Далее настраиваем профиль HotSpot-a на работу с RADIUS:

HotSpot MikroTik с авторизацией через SMS

И сам RADIUS сервер маршрутизатора.

HotSpot MikroTik с авторизацией через SMS

Добавляем в самый верх NAT таблицы правило:

/ip firewall filteradd chain=input comment="allows user manager to work with local hosts" src-address=127.0.0.0/24

HotSpot MikroTik с авторизацией через SMS

На этом настройка сервера закончена. Приступаем к железной части. В USB-разъем втыкаем модем, убеждаемся, что маршрутизатор его видит. System → Ports.

Как сделать sms авторизацию для wifi на оборудовании mikrotik? — Хабр Q&A

Устанавливаем Secret, включаем режим приёма сообщений. Tools → SMS.

HotSpot MikroTik с авторизацией через SMS

Отправляем тестовое сообщение на номер модема, убеждаемся, что оно принято

/tool  sms  inbox print

Удаляем тестовое сообщение:

/tool  sms  inbox remove

Добавляем скрипт обработки сообщений. System → Scripts:

HotSpot MikroTik с авторизацией через SMS

Code:

/tool  sms  set receive-enabled=yes
:local smsPhone
:local smsMessage
:local logMessage
delay 2;

:foreach i in=[/tool  sms  inbox find] do={
:set smsPhone [/tool  sms  inbox get $i phone];
:log info $smsPhone
:local date [/system clock get time]
:local hour [:pick $date 2]
:local min [:pick $date 35]
:local sec [:pick $date 68]
:local pass 27394
:set pass ($hour * $min * $sec)

:if ($pass = ) do {:set pass 6524}

#:log info $pass
:set logMessage "$date. Get SMS. Genegating $smsPhone->$pass"

/tool user-manager user remove [/tool user-manager user find username=$smsPhone]
/tool user-manager user add customer=admin disabled=no username=$smsPhone password=$pass shared-users=1 phone=$smsPhone
/tool user-manager user create-and-activate-profile  customer=admin profile=trial1 $smsPhone

:set smsMessage "Login: $smsPhone Password: $pass"
:log info $smsMessage

:if ([:len $smsPhone]>10) do {
/tool sms send usb1 $smsPhone message="$smsMessage"
}
/tool sms inbox remove $i
delay 10
#
delay 1;
}

System → Sheduler создаём новое задание, которое каждую минуту будет запускать этот скрипт.

HotSpot MikroTik с авторизацией через SMS

Скачиваем с маршрутизатора стартовую страничку хотспота, внедряем в неё информацию о номере, на который нужно отправить SMS.

Похожее:  Настраиваем IKEv2 VPN-сервер на роутерах Mikrotik с аутентификацией по сертификатам - Записки IT специалиста

HotSpot MikroTik с авторизацией через SMS

Проверяем работу системы. Вот, собственно, и всё. Сделано за 15 минут на коленке но работает, сильно не пинайте.

В планах разобраться как отправлять SMS со страницы авторизации, чтобы не заставлять пользователя два раза вводить номер своего сотового телефона.

LumberJack

Как сделать sms авторизацию для wifi на оборудовании mikrotik?

Приветствую коллеги!

Озадачился созданием wifi hotspot в гостиничном комплексе для гостей, но чтобы не нарушать закон необходима авторизация клиентов путем смс. Вариантов масса кто то делает своими руками путем usb модемов, кто то использует сторонние сервисы “студентов программистов”, так же есть сервисы от Мегафон и Билайн. Что из этого выбрать, голова кругом, кто то берет абонентку, кто то за смс.

Гостиничный комплекс из 6 корпусов ресторан отдельное здание, народу в сезон от 50 до 300 человек, вне сезона 10-30 человек. Сетка создана на оборудовании Mikrotik rb951ui-2hnd порядка 20 штук, все это работает на CAPsMAN v2. Сейчас сеть просто запаролена и гостю выдается пароль при заселении (не индивидуальный).

Главный вопрос что лучше своя собственная система или сервис (плюсы и минусы)?
Критерии выбора: сбор базы телефонов и возможность менять дизайн страницы авторизации под нужды отдела маркетинга, ну и собственно соблюдение закона, отказоустойчивость и 100% доставка смс.

Вообще кто сталкивался с данной задачей поделитесь опытом.

Заранее спасибо!

1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (1 оценок, среднее: 5,00 из 5)
Загрузка...

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Adblock
detector