HotSpot на оборудовании MikroTik с авторизацией через SMS —

$string=’:global mac; :foreach a in=[/ip arp find where address=’.$ip.’ dynamic=yes ] do={:set mac [/ip arp get $a mac-address ]; :put $mac;}’;$mac = ssh_exec($router, $string);preg_match(‘/..:..:..:..:..:../’,$mac , $matches);@$mac = $matches[0];

//отправляем смс с 3G-модема, воткнутого в микротик

$string=’/tool sms send usb3 channel=3 7′.$tel.’ message=»Ваш код WiFi: ‘.$code.’»‘; ssh_exec($router, $string);

//или с модема, воткнутого в комп, например, с помощью gnokii (меньше заморочек с кириллицей)

$sms = «Ваш код WiFi: «.$code; $sms = str_replace(‘ ‘, ‘ ‘, $sms); $sms = system(«sudo -u www-data /var/www/html/sms-send.sh 7″.$tel.» «.$sms);

//sms-send.sh

: настройка авторизации wifi-пользователей по sms

Авторизация доступа в WiFi сеть по СМС 

Публичный доступ в WiFi сеть теперь как известно регламентирован – в июле 2022 года вышло постановление правительства № 758, суть которого сводится к тому, что анонимным пользователям заходить в открытую WiFi сеть теперь нельзя. Всех пользователей нужно авторизовывать, да еще полгода хранить данные о них самих, времени и объеме оказания услуг. Для владельцев кафе, ресторанов, магазинов, отелей, клиник, турагентств и прочего бизнеса из сферы обслуживания, что хотят завлечь клиентов бесплатным вай-фаем – это неподъемная задача. Выбор тут простой: либо идти на поклон крупным операторам связи, отдавая им прибыль за предоставление телематических услуг, либо выдергивать кабель из порта RJ45 точки доступа своего любимого заведения. Но есть третий способ, которым хочу поделиться.

Способ хорош тем, что:

А) закон не нарушаем и авторизуем пользователей по строго закону, то есть по СМС, со всеми необходимыми данными идентификации личности.

Б) деньги операторам не платим, беспроводный бизнес им на откуп не отдаем.

Единственный минус – нужно приобрести контроллер Edimax PRO APC500 и потратить время на его настройку. В опытных руках настройка занимает три минуты и даже меньше – ровно столько длится ролик:

“>

Собственно, этой настройке и посвящена короткая статья.

Теперь по порядку:

1. Включаем контроллер Edimax APC500 в сеть. Наличие точек или готовых развернутых сетей Wi-Fi не обязательно. Captive portal можно включать и выключать в любой момент. Или переключаться между пресетами.

Контроллер Edimax APC500

2. Если в сети присутствует DHCP сервер – нужно найти какой IP получил контроллер. Если DHCP сервера нет – IP по умолчанию 192.168.2.1 и видим страницу настроек NMS (здесь и далее скриншоты с приведенного выше видео):

Страница настроек NMS

3. Выбираем: NMS Settings>System Accounts

NMS Settings - System Accounts

В контроллере АРС500 сервис отправки СМС уже встроен и работает на базе двух предустановленных операторов связи. Они используют заведомо лучшее ПО и аппаратную часть, нежели оборудование, которое может использовать отдельная частная компания, например, GSM-шлюз. (Понятно, что кафе или кофейня даже и думать не могут о таком шлюзе, да он им и не нужен). Сервис же оператора, крайне дешев и, насколько я знаю, может осуществлять рассылки до миллиона СМС и не требует наличия повышенного внимания и для поддержки.

Похожее:  Ваш личный кабинет формируется. Пожалуйста, попробуйте зайти позже - что значит

В России, такой сервис предоставляет провайдер Stream Telecom (Стрим Телеком). Допускаю, что много кто еще, но прямо в контроллере Эдимакса он уже прошит заранее как родной. Поэтому для начала необходимо выполнить подготовительную работу – зарегистрироваться на сайте оператора и завести свой аккаунт. Вы получите логин и пароль, которые нужно будет ввести в меню контроллера.

меню контроллера

На этом настройки авторизации по СМС завершена.

4. Теперь нужно установить, кто из Wi-Fi пользователей будет авторизовываться посредством СМС. Для этого необходимо создать две группы пользователей: Frontdesk и Guest group. Далее мы должны установить, что пользователи будут динамические и по необходимости выбрать веб-сайт для переадресации.

HotSpot на оборудовании MikroTik с авторизацией через SMS —

Для настроек администратора, уведомления СМС не требуется, но нужно включить метод проверки подлинности – SMS. Выберите код страны 7 и выберите метку Use Cell Phone numbers as Username.

5. Последняя операция настройка Captive portal, где можно настроить сообщение, которое получит пользователь (приветствие, название заведение, рекламные объявления и проч.)

Captive portal

6. Так же можно настроить саму страницу Captive Portal, куда вывести свои лого, шаблоны графики, полностью или частично изменить лицензионное соглашение. Как видно, ничего заумного в настройке нет, ее может освоить любой человек, хоть немного знакомый с администрированием.

Администрирование Captive portal

Ну собственно, вот и все, владелец теперь может не опасаться штрафов за незаконную раздачу трафика, а с учетом того, что он вот-вот собирается открывать флигель с мини-гостиницей, ему придется докупать еще десяток точек и управлять с ими все равно будет удобнее с контроллером, чем без него. Соответственно, вложение единоразовое и надолго, а, следовательно, стратегически осмысленное.

Данный материал является частной записью члена сообщества Club.CNews.
Редакция CNews не несет ответственности за его содержание.

Hotspot на оборудовании mikrotik с авторизацией через sms —

До недавнего времени бюджетный спутниковый доступ в интернет был исключительно ассиметричным (запрос проходил по наземным сетям связи, ответ “падал с неба”). Сейчас же одна известная трёхцветная кампания предлагает двунаправленный комплект по вполне демократичным ценам. Область применения, в первую очередь, для организации доступа в сеть в местах, куда прокладка наземной линии связи либо невозможна, либо слишком дорога.

Заказчиком была поставлена задача обеспечить доступом в Интернет охотбазу, расположенную в 60 километрах от города. Выезд на место показал наличие сотовых сетей, но 3G там только декларировался значком на дисплее телефона, а по факту — отсутствовал совсем. Попытка договориться с ОпСоСами о пробросе оптики от базовой станции, видневшейся вдали, привела к коммерческому предложению в 700 тысяч рублей за установку и 69 тысяч в месяц абонплаты за канал, что не могло не радовать. В тяжких раздумьях вбил в поисковую строку «Спутниковый интернет» и, о чудо, понял, что это – спасение.

Похожее:  ИФНС России по г. Георгиевску Ставропольского края | ФНС России | 26 Ставропольский край

Для реализации проекта было закуплено:

Процесс монтажа и настройки комплекта описывать не буду, ибо он мало чем отличается от монтажа обычной телевизионной тарелки и ресивера.

Приёмник имеет 10/100 RJ-45, который мы подключаем к маршрутизатору. Процесс настройки HotSpot-a описан во многих источниках, я делал по вот этому мануалу.

Ну а дальше – самое интересное. Так как лень, как известно, двигатель прогресса и ручками заносить каждого пользователя было лень решил автоматизировать процесс посредством рассылки пары Login/password через SMS.

Сначала необходимо скачать и установить на Mikrotik пакет user-manager. Сразу после перезагрузки панель управления будет доступна по адресу http://IP.of.you.router/userman.

Login: admin без пароля. Немедленно меняем. Для работы RADIUS сервера на Mikrotik создадим виртуальный маршрутизатор. Открываем терминал и вводим:

/tool user-manager router add customer=admindisabled=noip-address=127.0.0.1name=virtualshared-secret=123456789

Результат:

HotSpot MikroTik с авторизацией через SMS

Создадим профиль trial1:

HotSpot на оборудовании MikroTik с авторизацией через SMS —

Преднамеренно сделано так, чтоб каждый пользователь работал на максимально возможной скорости. Система очень гибкая, имеет массу возможностей, описанных в документации.

Далее настраиваем профиль HotSpot-a на работу с RADIUS:

HotSpot MikroTik с авторизацией через SMS

И сам RADIUS сервер маршрутизатора.

HotSpot MikroTik с авторизацией через SMS

Добавляем в самый верх NAT таблицы правило:

/ip firewall filteradd chain=input comment="allows user manager to work with local hosts" src-address=127.0.0.0/24

HotSpot MikroTik с авторизацией через SMS

На этом настройка сервера закончена. Приступаем к железной части. В USB-разъем втыкаем модем, убеждаемся, что маршрутизатор его видит. System → Ports.

HotSpot на оборудовании MikroTik с авторизацией через SMS —

Устанавливаем Secret, включаем режим приёма сообщений. Tools → SMS.

HotSpot MikroTik с авторизацией через SMS

Отправляем тестовое сообщение на номер модема, убеждаемся, что оно принято

/tool  sms  inbox print

Удаляем тестовое сообщение:

/tool  sms  inbox remove

Добавляем скрипт обработки сообщений. System → Scripts:

HotSpot MikroTik с авторизацией через SMS

Code:

/tool  sms  set receive-enabled=yes
:local smsPhone
:local smsMessage
:local logMessage
delay 2;

:foreach i in=[/tool  sms  inbox find] do={
:set smsPhone [/tool  sms  inbox get $i phone];
:log info $smsPhone
:local date [/system clock get time]
:local hour [:pick $date 2]
:local min [:pick $date 35]
:local sec [:pick $date 68]
:local pass 27394
:set pass ($hour * $min * $sec)

:if ($pass = ) do {:set pass 6524}

#:log info $pass
:set logMessage "$date. Get SMS. Genegating $smsPhone->$pass"

/tool user-manager user remove [/tool user-manager user find username=$smsPhone]
/tool user-manager user add customer=admin disabled=no username=$smsPhone password=$pass shared-users=1 phone=$smsPhone
/tool user-manager user create-and-activate-profile  customer=admin profile=trial1 $smsPhone

:set smsMessage "Login: $smsPhone Password: $pass"
:log info $smsMessage

:if ([:len $smsPhone]>10) do {
/tool sms send usb1 $smsPhone message="$smsMessage"
}
/tool sms inbox remove $i
delay 10
#
delay 1;
}

System → Sheduler создаём новое задание, которое каждую минуту будет запускать этот скрипт.

Похожее:  ПИК-Комфорт – личный кабинет – вход клиента pik-client || Управдом пик личный кабинет

HotSpot MikroTik с авторизацией через SMS

Скачиваем с маршрутизатора стартовую страничку хотспота, внедряем в неё информацию о номере, на который нужно отправить SMS.

HotSpot MikroTik с авторизацией через SMS

Проверяем работу системы. Вот, собственно, и всё. Сделано за 15 минут на коленке но работает, сильно не пинайте.

В планах разобраться как отправлять SMS со страницы авторизации, чтобы не заставлять пользователя два раза вводить номер своего сотового телефона.

LumberJack

Где необходима идентификация пользователей по системе хот-спот?

  1. В ресторане/кафе/торгово-развлекательном центре/салоне красоты. Создайте комфортное пространство для работы и отдыха ваших клиентов. Ненавязчиво продавайте услуги и товары прямо на странице авторизации, рассказывайте об акциях и скидках.
  2. В гостинице/отеле/санатории. Анонсируйте мероприятия и акции прямо на странице авторизации.
  3. На мероприятии/стадионе/концерте. Позвольте посетителям делиться фотографиями и видео с мероприятия, создайте мобильное приложение для болельщиков и показывайте повторы с матчей и концертов.

Как сделать wi-fi авторизацию по звонку?

Шаг 1. Пользователь совершает бесплатный звонок.

Шаг 2. Система определяет его номер и вводит в базу данных.

Шаг 3. При авторизации в системе пользователь вводит номер своего телефона в качестве пароля к wi-fi.


Через номер телефона поступает информация о mac-адресе устройства.

Идентификация с планшета или ноутбука происходит также. Посетитель должен выбрать удобный способ авторизации (совершить бесплатный звонок или получить СМС с кодом). Ввести свой номер телефона с любого устройства в качестве пароля. Система обеспечит бесплатный доступ к интернету тому устройству, с которого введен пароль.

Как сделать wi-fi авторизацию по смс?

Шаг 1. Новый пользователь при подключении к сети вай фай вводит свой номер телефона.

Шаг 2. Получает СМС с кодом.

Шаг 3. Вводит полученный код на страницу авторизации.

Шаг 4. Входит в интернет.

Нужно настроить wi-fi авторизацию?

Преимущества wi-fi авторизации для бизнеса

  • выполнение требований закона;
  • привлечение новых клиентов благодаря бесплатному и быстрому доступу к интернету;
  • безопасное хранение корпоративных данных;
  • возможность регулировать скорость трафика, блокировать отдельные сайты и пользователей;
  • система управления рекламой на предприятии.

Что спроектировать беспроводную вай фай сеть с долгим сроком службы, а также подключить незаменимую систему идеантификации пользователей, оставьте заявку на нашем сайте или по указанному телефону.

Преимущества wi-fi авторизации для посетителей

  • регистрация только один раз;
  • неограниченное количество устройств может быть авторизовано по одному номеру телефона;
  • идентификация по звонку – абсолютно бесплатно, по СМС – за небольшую плату в размере 1-2 рубля.
  • идентификация иностранных пользователей, подключенных к роумингу. Нужно только указать код страны.
1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (Пока оценок нет)
Загрузка...

Добавить комментарий

Ваш адрес email не будет опубликован.

Adblock
detector