Настройка MikroTik Hotspot, гостевая сеть WiFi | NEW 2021

Что нужно кроме точки доступа wifiроутера mikrotik

Оборудование MikroTik не было бы таким популярным, если бы для каждого решения производили отдельные устройства(как в Cisco, Tp-Link, Ubiquiti). Поэтому устройство с уровнем лицензии Router OS Level 4 и прекрасными показателями аппаратных возможностей позволяют использовать службу Hotspot без привлечения дополнительного оборудования.

Что такое hotspot?

Само по себе HotSpot – это просто точка доступа к Wi-Fi сети, созданная для подключения устройств к локальной сети без проводов. При этом часто возникает потребность организации раздельных HotSpot’ов, для рабочей и гостевой сети. Гостевая сеть должна быть отделенной от основной сети, позволяющей пользоваться беспроводным доступом к сети интернет без доступа к рабочей локальной сети и зачастую быть доступной без ввода паролей, тогда как локальная сеть напротив, должна быть защищена и недоступна посторонним.

Оборудование MikroTik RouterBOARD и ее RouterOS предоставляет широкие возможности настройки разделенных HotSpot’ов, помогая системным администраторам не только быстро создать разделенные точки доступа к сети, но и гибко настраивать их возможности и ограничения. Например для общественных мест можно настроить доступ к сети, только после просмотра рекламы.

Настройка локальной сети как правило не вызывает вопросов, по этому мы рассмотрим  простое создание гостевого хотспота на  MikroTik RouterOS с ограничениями и возможностью показа рекламы или перехода на сайт провайдера.

Web форма hotspot для mikrotik

После завершения работы мастера по созданию Hotspot, во внутренней памяти создается html страница. Для авторизации нужно использовать учётную запись, которая была введена в качестве пользователя Hotspot.

Данную страницу можно заменить на любую другую форму. Как правило это страница приветствия, с переходящей кнопкой(ссылкой).

Добавление бриджа для административной сети

В меню Bridge создайте бридж интерфейс с именем bridge_work, а бридж для хотспота переименуйте в bridge_hotspot.

В меню IP — Address добавьте IP-адрес 192.168.11.1/24 для интерфейса bridge_work.

На вкладке Ports добавьте 9-й сетевой порт ether9 в бридж bridge_work, чтобы потом с помощью ноутбука проверить работу административной сети.

Добавляем wi-fi интерфейсы в соответствующие бриджы

Теперь добавим каждый Wi-Fi интерфейс в свой бридж.

Добавляем Wi-Fi интерфейс хотспота в свой бридж:

  • Откройте меню Bridge и перейдите на вкладке Ports.
  • Нажмите « ».
  • Выберите Interface: wlan_hotspot
  • Выберите Bridge: bridge_hotspot.

Аналогично добавляем Wi-Fi интерфейс административной сети в свой бридж:

  • Откройте меню Bridge и перейдите на вкладке Ports.
  • Нажмите « ».
  • Выберите Interface: wlan_work.
  • Выберите Bridge: bridge_work.

Настройка bridge интерфейса для hotspot

Для будущего Hotspot мы создадим отдельный Bridge-интерфейс, для этого нужно открыть в меню пункт Bridge на вкладке Bridge нажать  . Никаких дополнительных настроек нам не потребуется, сохраняем настройки по умолчанию.

После этого выберем интерфейс, который будет связывать наш Bridge и порт  роутера через который будут осуществляться гостевые подключения. Для этого откроем вкладку Ports и нажимаем  . Добавляем необходимые интерфейсы к новому Bridge как показано на скриншоте.

После этого, присвоим данному бриджу подсеть адресов, что бы все гостевые подключения находились в отдельной подсети. Для этого в в меню IP — Address и добавим для нашего bridge1 пространство адресов, например 192.168.10.1/24.

После произведенных действий можно переходить к настройкам HotSpot.

Настройка dhcp клиента

Наш провайдер выдает автоматические настройки по DHCP, поэтому выполняем следующие настройки:

  1. Откройте меню IP — DHCP Client.
  2. Нажмите кнопку « »
  3. В появившемся окне в списке Interface выберите первый сетевой порт ether1.
  4. Нажмите кнопку Apply.

После этого на вкладке Status отобразятся IP адреса, которые получило устройство.

Настройка dhcp сервера

Откройте меню IP — DHCP Server, нажмите кнопку DHCP Setup и выполните следующие настройки:

  • DHCP Server Interface — bridge_work
  • DHCP Address Space — 192.168.11.0/24
  • Gateway for DHCP Network — 192.168.11.1
  • Address to Give Out — 192.168.11.2-192.168.11.254
  • DNS Servers — 192.168.11.1
  • Lease Time — 3d 00:00:00. Можно указать меньшее время аренды IP-адреса, но поскольку это административная сеть, то не желательно часто менять IP-адреса.
Похожее:  Обратная связь | Минстрой России

После этого DHCP сервер готов к работе.

Настройка dns

  1. Откройте меню IP — DNS;
  2. Поставьте галочку Allow Remote Requests, чтобы клиенты получили выход в интернет;
  3. Можете указать альтернативный DNS сервер Google 8.8.8.8, чтобы не зависеть от DNS сервера провайдера.
  4. Нажмите кнопку OK.

Настройка mikrotik hotspot

В Mikrotik RouterOS есть встроенный мастер создания хотспотов, воспользуемся им, для этого перейдем в меню IP – Hotspot и на вкладке Servers нажмем кнопку Hotspot Setup. Запустится мастер быстрой настройки, фактически в нем нет необходимости ничего настраивать, все настройки по умолчанию близки к оптимальным, плюс к этому RouterOS сама определит уже созданные нами параметры IP для будущей сети.

Из настроек которые необходимо указать вручную, можно выделить только Hotspot interface где выбираем наш bridge1, а так же DNS сервер, где можно указать любой общедоступный, например 8.8.8.8 от Google или 77.88.8.7 от Яндекс с фильтрами безопасности.

 Поля SSL certificate, SMTP server, DNS name можно оставлять пустыми.

После создания Hotspot необходимо настроить ограничения для гостевой сети. Основными ограничениями будут скорость канала для клиентов и времени соединения. Что бы задать эти лимиты, перейдем на вкладку Server Profiles, выберем наш свежий хотспот для редактирования.

На вкладке Login снимем выбор с параметра Cookie, и поставим галочку Trial, после чего установим временные лимиты. Выбор ограничений сильно зависит от профиля использования сети. Trial Uptime Limit – это время, в течении которого клиенту разрешено пользоваться интернетом.

Настройка nat

Откройте меню IP — Firewall, перейдите на вкладку NAT, добавьте новое правило и укажите в поле Src. Address 192.168.11.0/24.

Перейдите на вкладку Action, выберите masquerade и нажмите кнопку OK.

После этого в конце списка правил NAT появятся правила для административной сети. Выше по списку расположены правила для HotSpot, которые создались автоматически.

Настройка wi-fi интерфейсов

Чтобы гости и сотрудники могли подключаться по Wi-Fi каждый к своей сети, нужно настроить Wi-Fi интерфейс роутера.

Настройка wi-fi сети hotspot’а в mikrotik

После всех подготовительных работ, можно переходить к настройке беспроводных интерфейсов Miktotik, если они у вас есть. Если в вашем RouterBOARD нет Wi-Fi адаптера, то можно просто подключить в настроенный разъем точку доступа(предварительно настроенную) и все будет работать, а этот раздел пропускать.

Открываем меню Wireless, на вкладке General укажите имя, например Name: wlan_hotspot и нажмите кнопку Advanced Mode для доступа ко всем настройкам беспроводного адаптера. На вкладке Wireless настроиваем основные параметры подключения.

  • Mode — ap bridge — включаем работу в режиме точки доступа.
  • SSID — MAIN-Wi-Fi — имя беспроводной сети
  • Radio Name — MAIN-RADIO — имя точки доступа, отображается при сканировании сети.
  • Scan List — 2400-2500 — диапазон сканирования сетей.
  • Wireless Protocol — 802.11 — работа в режиме стандартного Wi-Fi.
  • Frequency Mode — superchannel — включение всех доступных частот.
  • Default Authenticate — режим ограничения по минимальному уровню сигнала.
  • Default Forward — отключим для запрета обмена данными между клиентами беспроводной сети.

Вкладка — Data Rates,  устанавливаем Rate Selection: advanced, параметр Rate как Configured и уберите все галочки со скоростей B режимов вверху и внизу.

Вкладка Advanced:

Вкладка HT: можно активировать все переключатели, это включит режим  MIMO, позволяющий повысить скорость передачи данных, хоть и в ущерб зоне покрытия

Похожее:  Перевод «Авторизация» с русского на английский язык с примерами -

На Вкладке WDS убедимся что он отключен.

На вкладке Nstreme снимите галочку Enable Polling.

Вкладка Tx Power Можно менять параметр Tx Power Mode, для регулировки мощности выходного сигнала. Мобильные телефоны обычно имеют синал не выше 16dbm, по этому не стоит выставлять значение слишком высоким. Высокая мощность точки может заглушить слабые сигналы клиентов.

Необходимо изолировать клиентский трафик между точками, запретив клиентам обмениваться данными, это снизит зашумленность сети снизив общую нагрузку.

Изолировать клиентов можно проделав следующее:

  • Каждую точку подключать в отдельном VLAN;
  • Изолированные VLAN сети объелинить на едином общем Bridge.

Создадим новый фильтр в меню Bridge на вкладке Filters. Перейдите в General — Bridges и установите  In.Bridge и Out.Bridge наш интерфейс bridge_hotspot.

На вкладке Action, делаем drop

На этом настройку хотспота можно считать завершенной. Останется только довести некоторые индивидуальные параметры, например административную сеть или дополнительные сети со своими ограничениями и пользователями. Дополнительно есть возможность настройки отображение рекламы пользователям при подключении к сети.

Настройка ограничений скорости

Сотрудники административной сети могут качать торренты или файлы из интернета и тем самым тормозить работу других сотрудников. Чтобы этого не происходило, нужно настроить ограничения скорости для сотрудников.

Для ограничения скорости и эффективного использования пропускной способности будем использовать шейпер PCQ. Преимущество шейпера PCQ в том, что при превышении скорости клиентом, шейпер не отбрасывает данные клиента сразу, а буферизирует их, увеличивает задержку и информирует приложения о том, что нужно снизить скорость.

Первым создаем правило ограничения скорости загрузки. Откройте меню Queues, перейдите на вкладку Queues Types и создайте новую запись с следующими параметрами:

  • Type Name — PCQ_Download.
  • Kind — PCQ.
  • Rate — 5M — ограничение скорости загрузки на одного сотрудника.
  • Limit — 500 — размер буфера пакетов на одного сотрудника.
  • Total Limit — 20000 — размер буфера пакетов на всех.
  • Поставьте галочку Dst. Address.
  • Нажмите OK.

Второе правило будет ограничивать скорости отдачи:

  • Выделите предыдущее созданное правило и нажмите кнопку Copy (серая лейка).
  • В поле Type Name укажите имя PCQ_Upload.
  • Поставьте галочку напротив Src. Address (не Dst. Address.).
  • Нажмите OK.

Мы создали два правила для ограничения скорости загрузки и отдачи. Теперь применим их для административной сети:

  • Перейдите на вкладку Simple Queues.
  • Нажмите « » для создания нового правила.
  • Перейдите на вкладку Advanced.
  • Interface выберите bridge_work — бридж интерфейс административной сети.
  • В разделе Target Upload в списке Queue Type выберите правило PCQ_Upload.
  • В разделе Target Download в списке Queue Type выберите правило PCQ_Download.

Это правило ограничит скорость всем сотрудникам без добавления их в Address List.

Протестируем работу ограничений скорости. Подключаем ноутбук в 9-й сетевой порт роутера и ставим торрент на загрузку. После этого нажмите правой кнопкой мыши на интерфейсе bridge_work и выберите в меню Torch. 

На этом настройка внутренней сети организации завершена. Мы создали на маршрутизаторе два бридж интерфейса:

  • bridge_hotspot — для подключения гостей с переадресацией на рекламную страничку;
  • bridge_work — для сотрудников организации.

Настройка параметров хотспота

В роутерах MikroTik есть встроенный функционал хотспота. Приступим к его настройке.

  1. Откройте меню IP — Hotspot
  2. Нажмите кнопку Hotspot Setup
  3. В открывшемся окне выберите Hotspot Inerface: bridge1 и нажмите кнопку Next.
  4. В поле Local Address of Network указывается IP-адрес хотспота 192.168.10.1/24. Роутер автоматически его определил, поэтому жмем Next.
  5. В поле Address Pool of Network указывается диапазон IP-адресов, которые будут автоматически выдаваться клиентам. Оставим диапазон 192.168.10.2-192.168.10.254 без изменений и нажимаем Next.
  6. На запрос сертификата отвечаем none и нажимаем Next.
  7. IP-адрес SMTP сервера нам не нужен, поэтому ставим 0.0.0.0
  8. В качестве DNS сервера укажем IP-адрес сервера Google 8.8.8.8
  9. Имя DNS сервера оставляем пустым.
  10. В следующем окне имя пользователя и пароль не меняем.
Похожее:  настройка подключения по mac адресу

После этого настройка завершена.

Настройка подключения к провайдеру

Подключаем кабель провайдера в первый порт роутера. Напротив интерфейса ether1 появится буква R.

Настройка правил firewall для гостевой сети hotspot

Исходя из того, что роутер MikroTik hAP ac2 был предварительно настроен и содержит активные правила Firewall, достаточно добавить несколько правил для Hotspot, сохранив общую структуру Firewall. Эти правила также подойдут для большинства Firewall, которые имеют определенные производственные особенности.

Разрешить пользователям hotspot пользоваться интернетом

Настройка находится в IP→Firewall→Filter Rules

Запретить пользователям hotspot обращаться на любой интерфейс кроме wan

Запретить пользователям hotspot обращаться на роутер mikrotik

/ip firewall filter
add action=accept chain=forward comment=Hotspot in-interface=Bridge-Hotspot 
out-interface-list=WAN
add action=drop chain=forward in-interface=Bridge-Hotspot out-interface-list=!WAN
add action=drop chain=input in-interface=Bridge-Hotspot

Настройка сети для администрации

Сотрудникам организации нужно создать отдельную сеть без переадресации на страницу приветствия.

Ограничение скорости для гостевой сети hotspot в mikrotik

В рамках примера, все гостевой сети будет выделено 10Мб.

Ограничение скорости для гостевой сети

Настройка находится в Queues→Simple Queues

/queue simple
add dst=pppoe-out1 max-limit=10M/10M name=Queue-Hotspot target=10.5.50.0/24

Также можно использовать правила приоритезации трафика.

Перенаправление клиентов на рекламную страничку

Если вы хотите клиентам показывать рекламную страницу, то нужно переделать html страницу авторизации MikroTik.

Откройте меню Files и удалите файлы alogin.html и status.html. Скопируйте файл login.html на компьютер путем перетаскивания мышкой.

Откройте в браузере файл login.html, наведите мышку на ссылку сlick here, скопируйте адрес ссылки и запишите в блокнот. Ссылка выглядит следующим образом:

Подготовка сетевых интерфейсов, для создания mikrotik hotspot server

В качестве интерфейса для Hotspot будет создан Bridge, который будет содержать в себе два виртуальных wlan на 2,4 и 5ГГц.

Создание bridge для hotspot

Настройка находится в Bridge→Bridge

Поставить оценку

Назад к списку статей

Предварительная подготовка точки доступа wifiроутера mikrotik

В качестве тестового стенда будет использоваться маршрутизатор(роутер) MikroTik hAP ac2. на котором предварительно нужно совершить два действия:

Сбросить mikrotik до заводских настроек

Настройка находится в System→Reset Configuration

Произвести базовую настройку

Для этого раздела настроек, можно воспользоваться инструкцией “Обзор и настройка роутера MikroTik hAP ac2→”

Проверка работы беспроводных сетей

Сканируем на ноутбуке беспроводные сети. Ноутбук нашел две наши Wi-Fi сети.

Сброс настроек роутера

При первом подключении к роутеру с помощью программы Winbox нужно сбросить заводскую конфигурацию, нажав кнопку Remove Configuration.

Если у вас такое окно не появилось, то очистку конфигурации можно сделать следующим образом:

  1. Откройте меню New Terminal;
  2. В терминале введите команду /system reset;
  3. Подтвердите сброс, нажав кнопку y на клавиатуре.

После перезагрузки появится окно очистки конфигурации, в котором нужно нажать Remove Configuration.

Установка пароля администратора

В конце измените стандартный пароль администратора на роутере MikroTik.

Этапы настройки hotspot в mikrotik

План по созданию Hotpot на маршрутизаторе(роутере) MikroTik будет состоять из последовательности:

  1. Создание интерфейса для Hotspot-а.
  2. Настройка сервера Hotspot-а;
  3. Web страниц для Hotspot-а;
  4. Создание правил Firewall, для ограничения доступа;
  5. Ограничение скорости для гостевой сети.
1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (1 оценок, среднее: 4,00 из 5)
Загрузка...

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Adblock
detector