Интеграция 1С и ИС МОТП – Группа компаний «В приоритете 1С» – Профессиональное сопровождение ПП 1С

Особенности новой системы маркировки табачных изделий

Отслеживание всех этапов, которые проходит табачная продукция, осуществляется с помощью ИС МОТП. Это информационная система, задачей которой является мониторинг оборота табачной продукции. Автором этой базы данных и программного обеспечения для нее является Центр развития перспективных технологий.

Главным регулирующим документом, который вводит в действие информационную систему и вменяет в обязанности субъектов предпринимательства вносить в нее данные, является закон №487-ФЗ. 

В соответствии с планом проведения эксперимента коробки с табачной продукцией, а также блоки с ними будут маркироваться специальном кодом формата Data Matrix. В нем содержатся следующие данные:

  • Информация о товаре, включая история начиная от момента изготовления. Данные берутся из информационной системы;
  • Идентификационный номер товара, который соответствует записи в общем каталоге табачной продукции;
  • Криптографический ключ, с помощью которого проверяется подлинность нанесенного штрих-кода. 

Код согласно рекомендациям в нормативных документах наносится на нижнюю или боковую часть коробки. Блоки с сигаретами маркируются кодом на боковой части. 

Для организации взаимодействия с ИС МОТП субъект предпринимательства, который осуществляет законную продажу сигарет и табачной продукции, обязан иметь:

  • Кассовый аппарата с установленным фискальным накопителем;
  • Устройство для сканирования двухмерных кодов с упаковок;
  • Утилиту в кассовом аппарате или компьютере, которая обеспечивает обмен данными с ИС МОТП. 

Получение информации о входящих в блок пачках сигарет (api честный знак ис мотп, бухгалтерия предприятия 3)

В некоторых случаях необходимо получить коды идентификации пачек (КИ) по блокам. К примеру, для наполнения расходной накладной при оптовой продаже.

Интеграция 1С и ИС МОТП - Группа компаний «В приоритете 1С» - Профессиональное сопровождение ПП 1С

В обработке используются типовые процедуры и функции общих модулей конфигурации Бухгалтерия Предприятия 3, имена модулей:
– ИнтерфейсАвторизацииИСМПСлужебный;
– ИнтерфейсМОТПКлиентСервер;
– ИнтеграцияИСМП;
– ИнтерфейсМОТПСлужебный.

Для работы обработки необходимо подключить и настроить двухмерный сканер, а также настроить электронную подпись для организации. После открытия обработки необходимо выбрать организацию, для которой доступна электронная подпись. Далее отсканировать коды маркировок блоков и нажать кнопку “Запросить информацию”.

Похожее:  АО "ИВЦ ЖКХ И ТЭК", ИНН 3445061691

Интеграция 1С и ИС МОТП - Группа компаний «В приоритете 1С» - Профессиональное сопровождение ПП 1С

Откроется табличный документ со списком КИ пачек блока по данным ИС МОТП.

Интеграция 1С и ИС МОТП - Группа компаний «В приоритете 1С» - Профессиональное сопровождение ПП 1С

Проверено на платформе 8.3.15.1830, конфигурации Бухгалтерия предприятия 3.0.80.40. Код модуля формы обработки ниже.


&НаСервере
Процедура ЗапроситьИнформациюНаСервере(ТабДок)
	ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
	Макет = ОбработкаОбъект.ПолучитьМакет("Макет");
	
	ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
	ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
	ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
	
	ТабДок.Очистить();
	ТабДок.Вывести(ОбластьЗаголовок);
	ТабДок.Вывести(ОбластьШапкаТаблицы);
	
	Для каждого СтрокаКодыБлоков из КодыБлоков Цикл
		Штрихкод = СтрокаКодыБлоков.Значение;
		КлючСессии = ИнтерфейсАвторизацииИСМПСлужебный.ПроверитьОбновитьКлючСессии(
		ИнтерфейсМОТПКлиентСервер.ПараметрыЗапросаКлючаСессии(Организация));
		
		ВозвращаемоеЗначение = Новый Структура;
		ВозвращаемоеЗначение.Вставить("ТребуетсяОбновлениеКлючаСессии", КлючСессии = Неопределено);
		ВозвращаемоеЗначение.Вставить("РезультатОтправкиЗапроса",       Неопределено);
		ВозвращаемоеЗначение.Вставить("ТекстОшибки",                    "");
		ВозвращаемоеЗначение.Вставить("ДанныеОбАгрегации",              Неопределено);
		ВозвращаемоеЗначение.Вставить("СодержимоеНедоступно",           Ложь);
		
		Если ВозвращаемоеЗначение.ТребуетсяОбновлениеКлючаСессии Тогда
			Сообщить("Не удалось получить данные из ИС МОТП. Требуется обновление ключа сессии.");
			Возврат;
		КонецЕсли;
		URLЗапроса = СтрШаблон(
		"v3/cises/%1/aggregated",
		КодироватьСтроку(
		Штрихкод,
		СпособКодированияСтроки.КодировкаURL));
		РезультатЗапроса = ИнтеграцияИСМП.ПолучитьДанныеИзСервиса(URLЗапроса, КлючСессии, ИнтерфейсМОТПКлиентСервер.ПараметрыОтправкиHTTPЗапросов());

		РезультатОтправкиЗапроса = ИнтерфейсМОТПСлужебный.ОбработатьРезультатОтправкиHTTPЗапросаКакJSON(РезультатЗапроса);
		
		ВозвращаемоеЗначение.РезультатОтправкиЗапроса = РезультатОтправкиЗапроса;
		
		Если РезультатОтправкиЗапроса.ОтветПолучен Тогда
			Если РезультатОтправкиЗапроса.КодСостояния = 200 Тогда
				ДанныеОбработки = ИнтерфейсМОТПСлужебный.ТекстJSONВОбъект(РезультатОтправкиЗапроса.ТекстВходящегоСообщенияJSON, Истина);
				Для каждого СтрокаДанных из ДанныеОбработки Цикл
					ОбластьДетальныхЗаписей.Параметры.КодБлока = Штрихкод;
					ОбластьДетальныхЗаписей.Параметры.КодПачки = СтрокаДанных.Ключ;
					ТабДок.Вывести(ОбластьДетальныхЗаписей);
				КонецЦикла;
			КонецЕсли;                      
		КонецЕсли;
	КонецЦикла;
	
КонецПроцедуры

&НаКлиенте
Процедура ЗапроситьИнформацию(Команда)
	ТабДок = Новый ТабличныйДокумент;
	ЗапроситьИнформациюНаСервере(ТабДок);
	ТабДок.Показать();
КонецПроцедуры                   

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	//КодыБлоков.Добавить("(01)04660077310165(21)0000A=""");
	ИспользоватьПодключаемоеОборудование = Истина;
КонецПроцедуры

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
	Штрихкод = Данные;
	//Штрихкод = "0104660077310165210000A=""800507500093S Uc";
	Штрихкод = 	"(" Лев(Штрихкод,2) ")" 
				Сред(Штрихкод,3,14)  
				"(" Сред(Штрихкод,17,2) ")" 
				Сред(Штрихкод,19,7);
	КодыБлоков.Добавить(Штрихкод);
	//Сообщить(Штрихкод);
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	// Попробуем подключить сканер штрихкода
	МенеджерОборудованияКлиентПереопределяемый.НачатьПодключениеОборудованиеПриОткрытииФормы(ЭтотОбъект, "СканерШтрихкода");
КонецПроцедуры

Приложения для взаимодействия с информационной системой

Разработчик программ 1С Бухгалтерия и других приложений на базе 1С Предприятие (версия 1С 8.3) уже принял меры по внедрению возможности взаимодействия с ИС МОТП в своих программных продуктах. Функциональность появится с обновлениями 1С, а именно – 1С ERP, 1С Розница, 1С Управление торговлей.

Получить консультации по поводу обновления 1С для и порядка использования программ 1С с ИС МОТП вы можете у специалистов «ГК в Приоритете» по указанным на сайте телефонам. 

Регистрация розничного продавца в системе маркировки обуви и настройка работы в 1с [1с:розница 2.3] :: маркировка

1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (1 оценок, среднее: 4,00 из 5)
Загрузка...

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Adblock
detector